Step by Step Task Guide for Local
Timetablers (for 2018-19 Timetable)
Part One
1)

ASAP – Preparation



2)

Check you still have access to Scientia.
Request refresher training on Scientia if required. Email david.boyle@qmul.ac.uk to
arrange.
01 March to 27 April - Submission of Requirements




3)

Page 2

Page 3

Check all modules are in Scientia
Module by module, check, edit and, create and remove activities
Update staff list in Reference Manager
31 May to 29 June - Review Draft Timetable and Request Changes

Page 13

Check draft timetables via spreadsheets provided and web timetables.



4)

Check room allocations meet requirements
Check web timetables for available alternative slots for unscheduled activities
Inform Timetabling Support of any change requests
06 July – 03 September -Student Allocations





5)

Check activity templates are set up correctly
Begin allocating students to activities
Investigate and resolve student clashes
Ensure teaching staff are allocated to activities
03 September – 15 October – Problem Solving
(and repeat in the run up to and beginning of Semester 2)



6)

See part 2

Check for unallocated students which may be the consequence of module selection changes.
Investigate and resolve Student clashes
From 15 October onwards – Other Room Bookings



See part 2

See part 2

Book non-teaching activities via WRB

Please note this guide is intended to aid with the main tasks that arise during the timetabling
timeline and does not go into detail about more technical/advanced functions of the timetabling
software. Please see http://www.timetablingsupport.qmul.ac.uk/myTimetable for further guidance.
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SECTION 1 - PREPARATION
If you haven’t logged on to Scientia recently, make sure you can still access the software. If you have
had your PC re-imaged or replaced you may find you are unable to log on. Log any issues with itshelpdesk@qmul.ac.uk as soon as possible.
Access to the software is via https://timetablesportal.qmul.ac.uk (Internet Explorer recommended).
Enter your usual QMUL login details when prompted:

Fig.1
Once you have logged in successfully, make sure that you can launch the current year’s timetable.
The year you have selected will have a white background as indicated below. Please note you may
have fewer years to choose from than the illustration suggests. The SCI1819 timetable will not
become available until 01 March.
Click on ‘Enterprise Timetabler’ to make sure you can still launch the application.

Fig.2

If the application does not load, contact its-helpdesk@qmul.ac.uk
as soon as possible
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SECTION 2 - DATA SUBMISSION
CHECKING MODULES ARE AVAILABLE
The very first task you should complete is to check that all modules that will be running in 2018-19
are available in the timetable. If any modules are missing, contact timetabling@qmul.ac.uk in the
first instance.
To check that all modules are available, log in to the 18-19 timetable by following the steps outlined
in the previous section.
When the application opens, make sure you have ‘Modules’ selected from the drop down list in the
Views panel (see below).

Fig.3
Next, we need to filter the modules to only those that are relevant to you. There are a couple of
ways to do this. One option is to place your mouse pointer over the header of the ‘Name’ column
and right-click.

This will then open a list of options.
From the list, select ‘Column Chooser’.
A list of additional columns will appear – from here
you can choose which ones to add.
Double click on ‘Department Name’ and close the
Column Chooser.
You will now see that this column has been added
to the View Panel.

Fig.4
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Place your mouse pointer in the top right corner of the ‘Department Name’ column header and a
small filter icon will appear (you may need to expand the column first).

Fig.5
Click on the filter icon and then select your department from the list. This will filter the modules to
only those that belong to your department.
Alternatively, from the option menu shown in Fig.4, select ‘Show Auto Filter Row’
This will insert an additional row under the column header.
Type into the auto filter row to filter modules by
name.
Typing the first few letters of your module code
should suffice (example given filters to all modules
that begin BUSM).

Fig.6
4

Now that we have filtered to only those modules which are relevant modules, you may wish to print
this so you have a hard copy.
To do this, click File>Print>View Selector
(This will open the list in print format, you will then need to select File>Print from the new window).
Alternatively, to save the list as an Excel File, click File>Export>View Items and save as an Excel file
to your chosen destination.
CHECKING ACTIVITY DETAILS
Once you have established that all your required modules are in the system, it is time to focus on
checking and amending activity details. It is advisable to do this module by module. See below for
the steps to take.
1) Click on the first of your modules from the list in the Views Panel. Any activities associated
with this module will be listed in the Activities Panel.
2) Customise the information that is displayed in the Activities panel by hovering your mouse
pointer over the ‘Name’ column, right clicking and selecting ‘Column Chooser’.

Fig. 7
3) In the customisation box that appears (see fig. 7), double click on the following headers to
insert the columns to your Activity Panel:
Teaching Week Pattern
Suggested Days
Suggested Time
Duration
Activity Type Name
Size
Allocated Staff Name
Location Suitabilities
Zone Name

You can remove any unwanted columns by rightclicking on the column header and selecting
‘Remove This Column’.
Once you have chosen your column settings, they
will automatically reload the next time you log in.

This should enable you to organise the timetabling information for each activity as below:

Fig. 8
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You should now be able to quickly check through your activities to make sure all information has
been provided and to identify where you need to make changes (see next section for how to do
this).
If you prefer, an alternative method to check through your activities would be to select all your
modules (hold down ctrl and select multiple modules from the list in the Views Panel, or Ctrl A to
select all if you have filtered to your own modules), then File>Export>Activities and save the data as
an Excel File to work through.
Remember, some of the information may have changed out of necessity to enable timetable
changes – all activities must be checked. Please do not assume all details are the same as were
originally entered in the previous year.
AMENDING ACTIVITY DETAILS
Depending on the type of information that needs to be amended, one of the two following routes
need to be taken:
Via the Activity Editor…
Name
Activity Type
Planned Size
Zone
Teaching Week Pattern
Duration of Teaching activity

Via the Resources Tab…
Day
Start Time
Location Suitabilities
Teaching Staff

Editing activity details via the Activity Editor
To open the Activity Editor (see fig. 10 below) Double click on the activity you wish to edit from the
Activities Pane.
From here you are able to edit the title of your activity by typing into the free text box. Please note
that the activity will appear on student, staff and web timetables with the title as displayed here.
To change the duration of the activity, click on the up/down arrow to increase/decrease the amount
of time (see fig. 9 below). Please note that the system uses units of 30 minute blocks – the total
number of hours are displayed to the right of this. The example below shows an activity duration of
2 hours:
Fig 9.
To change the Activity Type or the Zone, simply select whatever is most appropriate from the dropdown list.
To change the Teaching Week Pattern, click on the drop-down text next to ‘Availability’.
This will open a new window (see fig.10). From here you can choose to use a Named Availability or
select your own ‘custom availability’. Where possible, it is always advisable to use a Named
Availability. This reduces the chance of making a mistake when manually selecting weeks and also
ensures that if the teaching week pattern of the activity is updated accordingly if semester dates
change from one year to next.
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To select a named availability, simply select it from the list at the left of the box. You will see that the
weeks corresponding the selected Named Availability are greyed out in the week ribbon to the right
(helpful if you are unsure as to which named availability you need).

Fig. 10
If on the other hand you do need to use a custom availability, click on the tick box on the upper left
corner. This will enable you to then manually select which weeks you require by clicking on the week
ribbon (you can also de-select weeks by clicking on those that are already greyed out).
Once you have finished, click anywhere outside the box to return to the Activity Editor.
When you have made all the changes you need to make, click on ‘OK’ to return to the main screen.
To Save your changes, click on the disk icon at the top left of the screen:

Do this after every change in order to ensure your work is
saved
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Editing Activities via the Resources Tab
It is not possible to change the day, start time, location suitabilities or allocated staff via the Activity
Editor. This must instead be edited via the Resources Tab – see fig.11

Fig. 11
Making sure you have the correct activity selected in the Activities Pane, click on the Resources Tab
to access the Day/Time, Location and Staff requirements.
To make a change, click on the + symbol and select the options you require. Once you have made
your changes, click on

and then

to save your changes.

DELETING ACTIVITES
Please delete any activities that you no longer require. To do this, select the activity from the
Activities Pane, right click and select ‘delete activity’. (You will be asked to confirm that you want to
delete the activity). Remember to always click

to save any changes.

CREATING / COPYING ACTIVITIES
If you need to create new activities:
1) Make sure you have the correct module selected in the Views Pane.
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2) Ensure you have at least one week selected on the week ribbon (The new activity will by
default have the same teaching week pattern as the pattern of weeks you have selected, but
this can be edited later). Simply click on a week in the ribbon to select it – see Fig. 12, which
shows week 15 is selected.

Fig. 12
3) Click on the + symbol located just above the week ribbon, as shown in Fig.12 above.
4) The Activity Editor will open – fill in the required details as you would if you were editing an
existing booking (see page 6).
5) Fill in the remaining requirements in the Resources Tab (see page 8). Please also ensure that
all new activities which will require a teaching space have a location number set to 1 in the
resources tab (see fig.13).

Fig. 13
6) Remember to click

to save your changes.

Sometimes it may be simpler to copy an existing activity, particularly if you need to create multiple
new versions.
To copy an existing activity:
1) Select the activity you wish to duplicate from the Activities Pane
2) Click Edit>Copy Activities to create a single copy, or;
3) Instead of clicking, hover over ‘Copy Activities,’ and then select ‘Configure Copy Activities’
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From the configuration box, select
how many copies you wish to create
and select ‘Activity’ as the base.
Finally, click ‘Create’ to generate the
copies.
Please note that the copies will share
all attributes of the original.
You will also need to edit the titles of
your copies in order to make them
more easily identifiable in Course
Planner.
As always, write-back your changes
to save your work.
Fig. 14

ADDING NEW STAFF MEMBERS TO DATABASE
In order for them to be available for you to allocate to teaching activities, any new members of staff
must first be entered into Reference Data Manager. Please note that staff are rolled over from one
year to the next so you should only need to do this for new starters.
1) From the portal, select Reference Data Manager (RD) as indicated in Fig.15

Fig. 15
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2) When RD opens, click on ‘New’ next to Staff, in the Resources area as indicated in Fig. 16
below:

Fig. 16
3) A new form will open (see Fig.17) Complete the Name*, Department and Email Fields.
When you have entered this information, press ‘OK’.
*Please note that names should be provided in the following format:
Family Name, Given Name, Title (optional)
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Fig. 17
4) Click on

to save your work.

You should now be able to add this staff member to your activity in Enterprise Timetabler in the
normal way via the Resources Tab (see page 8).
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SECTION 3 – REVIEW DRAFT TIMETABLE
Once Timetabling Support have produced the draft timetable, you will be provided with the
following:




Spreadsheet detailing all scheduled activities and (separately) all activities that could not be
scheduled in the first round
A temporary link to the 2017-18 web timetables
Regular updates on teaching space availability (availability matrices)

It is very important that you check that all teaching space allocations are suitable for your needs.
Remember, space allocations will be made according to planned sizes and suitabilities submitted
during the data input period earlier in the year.
If there is a problem with the suitability of your room allocations, or you need to make changes to
your timetable, please contact timetabling@qmul.ac.uk as soon as possible and before 29 June
2018.
It is likely that it will not be possible to schedule all activities at the times that have been requested.
With the aid of the availability matrices supplied by Timetabling support, check for alternative
timeslots (or locations) via the temporary link to draft web timetables.
Room (or module) timetables can be selected from the menu on the temporary web timetables
homepage

Fig.18
Remember, you can select multiple rooms (or modules) at once by holding down the ctrl key when
making your selections.
Please also ensure that you select the correct Week Range before selecting ‘View Timetable’ to
ensure that you retrieve the required information.
Once you have found an alternative timeslot or venue, please contact timetabling@qmul.ac.uk as
soon as possible.

End of Part One
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